Apache tiene problemas de seguridad

Y esto afecta también a MacOS X.

Todos los servidores que corren bajo Mac OS X, y otros sistemas operativos pueden ser susceptibles de un ataque de “Denial of Service” (DoS).

El daño es mayor, si se llega a los número de procesos, que son utilizados prácticamente por el 100% de las máquinas hoy en día.

Múltiples peticiones a un CGI, prueden producir en “kernel panic” o una reducción drástica en el rendimiento de la máquina.

Los CGI (Common Gateway Interface) Son muy utilizados en Internet, y se utilizan, para carros de la compra, contadores, foros, etc … Estos CGI se pueden progamar en cualquier lenguaje como Perl o PHP, si el lenguaje no es compilado, y el servidor llama al “intérprete” cada vez que el programa es arrancado, lo que produce un excesivo proceso de carga.

El problema de estos ataques es la introducción de un Bash Script, el cual puede llegar a cambiar la IP de la petición, por la del ataque.

La única solución que parece haber para el servidor Apache o no utilizar CGI en él.

Fuente: Apple-X.Net

0 0 votos
Article Rating
Subscribe
Notify of
0 Comments
Opiniones Inline
Ver todos los comentarios
0
Me encantaría saber tu opinión, por favor, deja un comentariox
()
x