Solución al problema de Perl tras la actualización de seguridad 2009-001

signal-trabajando_file.pngParece que si usaste CPAN para mejorar tu instalación por defecto de Perl, entonces la actualización Security Update 2009-001mata” a Perl, de manera que tus scripts no se ejecutarán. Hay una discusión sobre esto en el los foros de soporte de Apple.

El arreglo mencionado en ese hilo funcionó para un usuario y es lo siguiente, todo hecho en la Terminal:

$ mkdir -p /SourceCache

$ cd /SourceCache

$ curl -O http://cpan.mirror.solnet.ch/authors/id/G/GB/GBARR/IO-1.2301.tar.gz

$ tar xzf IO-1.2301.tar.gz

$ cd IO-1.2301

$ perl Makefile.PL

$ make

$ make install

Haz notar que para algunos de los comandos anteriores, necesitas estar identificado como root, o ejecutarlo usando sudo.

Fuente: Mac OS X Hints

0 0 votos
Article Rating
Subscribe
Notify of
0 Comments
Opiniones Inline
Ver todos los comentarios
0
Me encantaría saber tu opinión, por favor, deja un comentariox
()
x