Apple finalmente elimina Python 2 en macOS 12.3

Apple ya no incluirá Python 2.7 con macOS 12.3, según las notas de la versión del desarrollador para la próxima actualización de software. Python 2 no ha sido compatible desde el 1 de enero de 2020 y ya no recibe correcciones de errores, parches de seguridad u otros cambios.

Apple dice que los desarrolladores deberían usar un lenguaje de scripting alternativo en el futuro, como Python 3, pero hay que señalar que Python 3 tampoco viene preinstalado en macOS. Los desarrolladores pueden ejecutar el stub /usr/bin/python3 en Terminal, pero recibirán como respuesta que instalen las herramientas de desarrollo de Xcode, que sí incluyen Python 3.

Apple advirtió que las futuras versiones de macOS no incluirían Python 2.7 en las notas de la versión para desarrolladores de macOS Catalina en 2019. En ese momento, Apple dijo que Python 2.7 estaba incluido en macOS por su compatibilidad con software heredado.

“Si su software depende de lenguajes de scripting, se recomienda que incluya el runtime dentro de la aplicación”, dice Apple.

Alf

Propietario de www.faq-mac.com.

0 0 votos
Article Rating
Subscribe
Notify of
0 Comments
Opiniones Inline
Ver todos los comentarios
0
Me encantaría saber tu opinión, por favor, deja un comentariox
()
x