El progreso de macOS traerá nuevas incompatibilidades con programas que usamos

Apple ha publicado un nuevo documento de soporte en el que indica que las extensiones del kernel (a las que llama «extensiones del sistema heredadas») no serán compatibles con futuras versiones de macOS porque «no son tan seguras o fiables como alternativas más modernas».

Apple ya informó a los desarrolladores de que macOS Catalina será el último macOS en ser completamente compatible con las extensiones de Kernel. Es razonable pensar que serán declaradas obsoletas en macOS 10.16.

Por ejemplo, una de las aplicaciones afectadas es el programa de antivirus gratuito Malwarebytes, que vio inundado su servicio de soporte al cliente después de la publicación de macOS 10.15.4 (que es cuando Apple ha comenzado a mostrar el aviso).

Detalles técnicos para los desarrolladores están disposables en un documento de Apple llamado «Deprecated Kernel Extensions and System Extension Alternatives

In this article

Join the Conversation