¿iPhone 5S o iPhone 6?

02/01/2013 por Carlos Burges

Apple ya está trabajando en los lanzamientos de producto de este año y entre ellos, están tanto una nueva generación de su iPhone además de una nueva versión de su sistema operativo iOS: de hecho, en los logs de aplicaciones de ciertos desarrolladores han comenzado a aparecer referencias al iPhone 6,1 además de iOS 7. Ambos productos no están disponibles en el mercado.

La pregunta es si Apple continuará con su actual política de "nueva generación - generación mejorada" como  ha ocurrido hasta ahora o lanzará un nuevo teléfono más allá de la versión mejorada del iPhone 5. El identificador mostrado, iPhone 6,1 no tiene que ser específico de un iPhone 6, ya que las diferentes versiones del iPhone 4, por ejemplo, mostraban ID acumulativos independientes de la generación del teléfono: el iPhone 4 era el 3,1, mientras que el iPhone 4S era el 4,1 (con algunas variaciones al respecto del decimal para los diferentes modelos).

Aunque, de todas formas, estos identificadores pueden ser falseados así como la versión del sistema operativo, en los logs también se muestra que las IPs relacionadas son del Campus de Cupertino, lo que cimenta la veracidad de estos comentarios.

Apple suele presentar los nuevos modelos de iPhone, junto con las versiones de su sistema operativo para dispositivos móviles durante la conferencia de desarrolladores, que tiene habitualmente lugar en junio en San Francisco y que incluye una Keynote dirigida por el CEO de la compañía, Tim Cook, en la que participan también varios ejecutivos de la empresa de Cupertino.

 

1
Comentarios
  • #1 por gabriel el 02/01/2013
    El artículo me ha parecido de verdad interesante. Por lo demás, me han divertido los efectos del resacón de año nuevo (del que no estoy exento): he podido descubrir, por ejemplo, la existencia del "iPhoen 4", modelo realmente "difernete" de los que hasta ahora conocía; "difernete", entre otras razones, porque utiliza un "distema" operativo, en lugar de los normales sistemas: es más, queriendo ser precisos, habría habría que hablar de un "distema op3erativo".
    Feliz año nuevo a todo el equipo de faq-mac
    Gabriel
  • #2 por yules el 02/01/2013
    Yo creo que el calendario de desarrollo de Apple está mediatizado por el mercado americano. El mercado americano del iPhone está basado, fundamentalmente, en teléfonos subvencionados por las operadoras con contratos con 24 meses de permanencia, lo que permite que pueda conseguirse un iPhone por $0, $99, $199, $299 o $299 según modelo y capacidad. Si Apple renovase completamente el teléfono a los 12 meses, sería un agravio para los que les quedan aún otros 12 de permanencia. El hacer una puesta al día, pero que es indistinguible visualmente del modelo anterior, hace que sus clientes puedan seguir esos ritmos de renovación bianuales sin molestarse porque su terminal "tan caro" se queda obsoleto de modo evidente para los espectadores.

    Ahora que algún bienpensante discrepe con aquello de que "lo importante es el interior" y "no hay que darle importancia a lo que piense la gente". ;-)
  • #3 por yules el 02/01/2013
    Evidentemente hay un error en el último precio, que debería ser $399.
  • #4 por Mendiaco el 02/01/2013
    Pues yo tengo que renovar en breve mi terminal, poseo un Iphone 3.
    El motivo, simplemente, que aplicaciones que hace un par de dias funcionavan, han dejado de funcionar, por ejemplo el whatsapp.
    Soy usuario de esta aplicación y la última actualización ha dejado de ser compatible con el sistema operativo del iphone 3.
    El motivo, pues muy sencillo. que los señores de apple, han restringido en las nuevas versiones de aplicaciones, que se pueda ejecutar con el 4.2.1.
    Ahora me encuentro con un movil que para mi funciona, pero sin poder acceder al whatsaap. ya que hay problemas de compatibilidad.
    Al renovar el terminal, primero, debo pensarme si continuare con apple o me ire a samsung. Lo que ha sucecido con el terminal, no me ha gustado nada de nada. Con lo que si algun lector supiera si esto tambien sucede con las versiones de android se lo agradeceria.
    Además de ver si es facil y practica la sincronizacion de los contactos y agenda.
    Me da, que apple a poco tardar, hara lo mismo con el iphone 5. Y bueno, a mi los terminales me duran mas que 3 años. Así que estoy por dar el salto inverso.

    Saludos.
  • #5 por Carlos Burges el 02/01/2013
    Mendiaco, ojo, puedes estar a gusto o a disgusto con Apple, pero que no te funcione el Whatsapp con el iPhone no es culpa de Apple, es culpa de Whatsapp y nada más.
  • #6 por Mendiaco el 02/01/2013
    Carlos estas totalmente equivocado.
    apple no permite publicar en su tienda, actualizaciones de aplicaciones con sistema operativo inferior a 4.2.1 que es el que utiliza el iphone 3g.
    Por lo tanto por mucho que quiera la empresa que desarrolla el whatsapp quiera continuar con la compatibilidad, apple no dejará que esa aplicación se pueda descargar de la itunes.
    Así como el kit de desarrollo de ios último no permite compatibilidad con versiones inferiores a 4.3 creo.
    Existe por internet miles de quejas al respecto.
    Te dejo por ejemplo un hilo en el foro de apple
    https://discussions.apple.com/thread/4634956?start=0&tstart=0

    La culpable es apple! Te guste o no.

    Te paso lo que dice oficialente "whats app"
    http://blog.whatsapp.com/index.php/2012/12/iphone3g/
  • #7 por Carlos Burges el 02/01/2013
    Yo lo veo de otra forma totalmente diferente y es una cuestión de servicio por parte Whatsapp: si realmente quisieran dar soporte al iPhone 3G, crearían una versión especial con las correspondientes herramientas compatibles.

    Al final, el soporte de las aplicaciones depende de los desarrolladores y de su interés de darlo independientemente de los cambios en la plataforma.
  • #8 por Acasita el 02/01/2013
    A mí también me interesa saber si hay algún teléfono que sincronice bien la agenda, el calendario etc con lo que hay en el Mac.

    No quiero pasar por Apple, de modo que si hay alguna opción, me alegraría. Sólo me interesa el calendario, los contactos y iTunes.
  • #9 por Acasita el 02/01/2013
    Claro. Si Acesa echa clavos en la autopista es culpa de Renault que se te pichen las ruedas porque no hace una versión del Clio con ruedas blindadas especial para las autopistas de Acesa.
  • #10 por Mendiaco el 02/01/2013
    Carlos a ver,
    No siempre depende del desarrollador, la version "especial" que comentas, no se puede colgar en el itunes store. Apple no lo permite, y el nuevo sdk no permite la ejecucion en ios inferior a 4.3. Te dejo el link de apple.

    https://discussions.apple.com/docs/DOC-3461

    Por lo que he leido en android, tu cuando compilas puedes compilar con diferentes, sistemas operativos.
    Te dejo un link si te descargas el sdk de android lo podras ver, pero simplemente si ves las capturas de pantalla veras lo que te digo
    http://www.xatakandroid.com/tutoriales/como-emular-android-en-tu-ordenador-windows-mac-o-linux

    Tu a lo que te refieres es al caso como android está planteado, en ese caso, si que el desarrollador es quien tiene toda la responsabilidad del desarrollo de las nuevas versiones. Por el contrario, apple te dice, si quieres salir en el itunes store, debes usar el últmo sdk. y con ese sdk te cuelo que no soporta la version de ios inferior a la 4.2.
    Si eso lo extiendes en el tiempo, veras que es una forma de promover la obsolescencia de los dispositivos ios de manera artificial.
  • #11 por rafa espada el 02/01/2013
    Es whatsapp el que ha cerrado el grifo a los de 4.2.1. La aplicación funciona bien, pero no consigue servicio porque Whatsapp lo ha capado.

    Motivos? no sé lo que dice Whatsapp pero son ellos los que tendrán que dar las explicaciones.
  • #12 por Carlos Burges el 02/01/2013
    Vamos a poner un ejemplo carísimo para que lo entendamos todos, escalando a lo bestia.

    Cuando Apple cambia de sistema operativo, herramientas de desarrollo, etc, es el desarrollador el que decide si va a soportar una plataforma o no en función de la aplicación: por ejemplo, cuando se actualiza OS X, Adobe se encarga, independientemente de la plataforma, de decidir que versiones son compatibles y de lanzar los oportunos parches para compatibilizar sus CS con los nuevos sistemas operativos. La gente no le reclama a Apple, le reclama a Adobe que es a quien le compraron la aplicación. Este caso es absolutamente el mismo, pero ahora, el desarrollador traslada la culpa a un tercero para justificar su falta de interés en dar soporte a los usuarios del iPhone 3GS.

    Un ejemplo de responsabilidad con los usuarios y el software que compran es Microsoft con Office, con versiones antiguas que son capaces de ejecutarse en sistemas operativos recientes (Office 2008, por ejemplo) de forma totalmente transparente y con las correspondientes actualizaciones incluso cuando tienen que mantener desarrollos paralelos para dar servicio ... porque es a ellos a los que les compraron el software.

    En iOS es todo mucho más complicado, por supuesto, porque todo tiene que pasar por el embudo de la App Store y eso dificulta muchísimo las cosas y el entorno que propone Apple es en muchas ocasiones muy hostil, pero la última responsabilidad es siempre del desarrollador.
  • #13 por Mendiaco el 02/01/2013
    rafa, en uno de mis links te he puesto lo que dice oficialmente whatsapp. Por favor leelo.

    Como dice carlos Burges en su ultimo post, el problema reside en el embudo de la applestore, donde te puedes descargar únicamente la última versión y no versiones anteriores.
    Os comento lo que sucede al usar el whatsapp a los usuarios de iphone 3g.
    El whatsapp funciona correctamente, mientras no tenga un error de conexion con el servidor. Al primer error de conexión, el whatsapp entiendo que comprueba el codigo que se ha enviado al servidor (el que te envian con el sms), pero han cambiado y han pasado de un codigo de 3 cifras a un codigo con guiones creo que de 6 cifras. Por ese motivo, no se puede validar en el servidor de whatsapp.

    Problema, whatsapp no puede mantener versiones antiguas, ya que el sdk no lo permite, en el caso que comentais de adobe, si claro adobe es el responsable de si quiere o no mantener, en este caso por mucho que whatsapp quiera, no puede.
  • #14 por Carlos Burges el 02/01/2013
    Mediaco, el SDK no permite actualizar versiones antiguas porque se ha retirado el soporte para el procesador, pero Whatsapp podría, si quisiera, seguir aceptando las llamadas de las aplicaciones "antiguas".

    Una cosa es la aplicación y otra cosa, la información transmitida y el protocolo de transporte. Lo que hace Whatsapp es decir que la culpa es de Apple cuando ellos deberían, simplemente, "abrir los correspondientes puertos" para el cliente "antiguo", por describirlo gráficamente de alguna manera y seguir dando soporte.

    Otra cosa muy diferente es que simplemente el número de usuarios del iPhone 3GS no sea ya el suficiente como para mantener una doble arquitectura para dar servicio por dos protocolos, pero eso ya no es un problema de Apple, es una decisión de ellos.
  • #15 por Mendiaco el 02/01/2013
    Carlos, a ver, lo que comentas tu, whatsapp, evidentemente lo podria hacer. Yo me he centrado en whatsapp, por poner el ejemplo principal. Pero son todas las aplicaciones de la applestore.
    De todas maneras lo de abrir puertos como dices, si cambias todo el protoclo de datos, como que se van a volver locos, los de whatsapp.
    Por contra, si tu quieres compilar para android, eliges en el sdk la version de android que deseas, y entonces si es responsabilidad del desarrollador.
    Aqui no, te lo impone apple, y apple es quien retira el soporte, y no me vengas que mantener las antiguas librerias y las nuevas sea un lio en el sdk, ya que es cuestion de usar uno u otro paquete.
    Es apple la principal responsable, de dejar sin soporte al ios 4.2.
  • #16 por Carlos Burges el 02/01/2013
    A ver, Mendiaco, que no es una cuestión de la aplicación, sino una cuestión de los protocolos. Es Whatsapp la que decide qué clientes "quiere escuchar" y "que clientes no quiere escuchar". Y como proveedores del servicio, ellos son los responsables.

    La excusa de Whatsapp es tan absurda como la que de un carpintero que dice que no clava más clavos porque le han cambiado el martillo.
  • #17 por Mendiaco el 02/01/2013
    Totalmente en desacuerdo contigo Carlos,
    Y te voy a empezar a poner otras veces que apple ha hecho lo mismo.
    Como por ejemplo el 10.8 que no lo puede ejecutar el macpro creo que del 2008.
    Problema del procesador? que va... si le instalamos chameleon arranca y con un buen rendimiento, pues pq no lo soporta apple. Simple quiere, que el cliente, le compre su nuevo macpro.

    Mira esta noche he estado en el gimnasio, y hablando con diferente gente, les he explicado lo del whatsapp, respuesta de todos, vaya mierda, yo no me compraria mas un iphone.
    Uno que se acaba de comprar el iphone 5. me dice, pues si a mi me hacen lo mismo tambien cambio de marca.
    Simplemente, considerar que un aparato electronico por tener 3 años esta obsoleto y se deje de dar soporte, lo siento pero no es de recibo. Creo que se dejo de vender el 7 de junio de 2010. Eso es dar soporte? para la creación de aplicaciones?
    Es lo mismo que cuando compre el macpro G5. Me siento igual de estafado.
    Esperaré unos dias entendiendo que las quejas igual rectifican, pero si me pasaré a android, Mas variedad de dispositivos, para poder encontrar el que se adapte a mis necesidades, y una targeta de memoria para poder guardar lo que yo desee.
    Bye Bye apple.
    Y espero que los demás usuarios del iphone 3G hagan lo mismo. Que para eso tenemos libertad de elegir marca.
  • #18 por cristianltorres el 03/01/2013
    Yo estoy de acuerdo con Mendiaco respecto a lo de whatsapp.
    Cuando Apple quita soporté para las versiones antiguas esta marcando una tendencia clara:
    Los desarrolladores pueden seguirla o no. Pero en el último caso estarían yendo "a contra corriente"
    Es Apple quien inicia esta tendencia y claramente no sale a cuenta " no seguirla."
    Pero si Apple no hubiese quitado el soporte o si ofreciera opciones (como las q comento Mendiaco q hay en otras plataformas) al menos esta dando más opción al desarrollador.
    Acaso whatsapp también dejo de funcionar para versiones antiguas d otros OS?
    Esta claro q sí los chicos de whatsapp quisieran hacer algo para seguir ofreciendo soporté a versiones antiguas, podrían hacerlo.
    Pero q sentido tiene cuando la propia Apple no ofrece dicho soporte? Creo q como desarrollador no te deja mucha opción. Al menos eficiente/viable.

    Por ultimo decir q tengo iPhone 5, iPad 3, MacBook Pro y iMac. O sea me gusta Apple, pero intento ser objetivo en mi opinión.
  • #19 por Mendiaco el 03/01/2013
    Cristian, es que además no te puedes descargar de la applestore una version antigua, para que funcione en el 3G.
    Si tienes cualquier aplicación operativa en el 3g, al realizar el desarrollador cualquier modificación, aunque sea una simple corrección del algún bug. Esa aplicación ya no se puede subir a la applestore. Ya que para ser subida, tiene que perder la compatibilidad con el sistema 4.2