Apple vuelve a bloquear la última versión del plug in de Java vía Xprotect

31/01/2013 por Carlos Burges

A pesar de que Oracle publicó una actualización de seguridad a primeros de este mes que solucionaba parcialmente una serie de graves vulnerabilidades que podían afectar a los usuarios que ejecutaran un applet de Java a través del navegador, Apple ha bloqueado de nuevo la más reciente actualización Java 7 Update 11.

El bloqueo de Java se realiza a través del sistema de protección Xprotect que se actualiza automáticamente sin la necesidad de la intervención del usuario. la última versión de Java en el Mac es la 1.7.0_11-b21 tal como muestra el panel de control de Java en Preferencias del Sistema. En la defición de Xprotect ahora se solicita como versión mínima para ser ejecutada la 1.7.11.22.

Para comprobar si se ha realizado la correspondiente actualización, puedes utilizar el comando de Terminal:

more /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist

Donde debes encontrar el siguiente texto:

com.oracle.java.JavaAppletPlugin

MinimumPlugInBundleVersion

1.7.11.22

Si no te figura la cifra 1.7.11.22 es que tu archivo de definición Xprotect todavía no se ha actualizado. Para forzar la actualización puedes usar el comando:

sudo /usr/libexec/XProtectUpdater

Te solicitará la contraseña de administrador. A continuación puedes comprobar tanto la fecha de actualización con:

defaults read /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta LastModification

Como la versión con:

defaults read /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta Version

Que debe devolverte la versión 2028.

 

0
Comentarios
  • #1 por Alquimista el 31/01/2013
    Ya me dado cuenta, ya. :-(
    Justo hoy ha dejado de funcionar la consola de FileMaker Server: aprovecho para actualizar FMS, bajo e instalo la última versión de Java, no igual que antes, pero al menos se puede ejecutar y volver a toquitearla...