Portada Foros Todo Mac Instalar Xcode en Mac OS X El Capitan 10.11.6

Este debate contiene 11 respuestas, tiene 2 mensajes y lo actualizó  Fai hace 2 días, 13 horas.

  • Autor
    Publicaciones
  • #144045

    Fai
    Participant

    El iMac 2008 no soporta actualizarse a macOS Sierra, y cuando pretendo instalar Xcode 8.3.3 desde la App Store, me dice que no puede ser porque requiere de versiones de mac 10.12 o superior.

    ¿Es posible instalar una versión anterior de Xcode en El Capitan? y en tal caso, ¿donde podría encontrarla?

    Un saludo.

  • #144046

    Fai
    Participant

    Vale, problema resuelto.

    Resulta que he comprobado mis apps compradas, y resulta que Xcode la tenía desde el 2013. Al darle a instalar, me ha dado la opción de descargar e instalar una versión anterior.

    El problema está en la gente que no la tenga comprada y no pueda actualizar su Mac a macOS Sierra.

  • #144047

    sault
    Participant

    También podrías instalar Sierra, si quieres.

    http://dosdude1.com/sierrapatch.html

  • #144048

    Fai
    Participant

    Gracias Sault, lo estuve considerando, pero es que es mi ordenador principal de trabajo, y no quiero tener problemas.

    He leído por internet que no se instalan las actualizaciones, o que daba problemas, y me da un poco de reparo actualizar a Sierra.

    ¿Sería posible instalarlo en un disco duro externo conectado por Firewire al iMac, y arrancarlo desde ahí? De esta forma mantendría íntegro el iMac ¿no es así?

    Gracias, y un saludo

  • #144049

    sault
    Participant

    Yo utilizo mac/os x hace ya muchos años, y lo tengo instalado en un Mac Pro 2008 que uso como segundo ordenador. Ya está muy pulido el parche. Cero problemas en el año y pico que lleva instalado con las actualizaciones, incluidas las de seguridad.

    De hecho, tengo un segundo disco con la beta High Sierra y va estupendamente

    Por Firewire corre sin problemas, y por USB, aunque va a ser bastante lento. Pero para que puedas probarlo te sirve a la perfección.

    ¿Has pensado en sustituir el DVD por una segunda unidad de disco?

  • #144050

    Fai
    Participant

    Pues es que aunque parezca mentira, la unidad de dvd funciona aun perfectamente, y no necesito más almacenaje interno.
    De hecho, por el iMac han pasado ya varios discos duros que he ido sustituyendo con el paso del tiempo por el que venía de fábrica, hasta que hace unos meses le instalé el SSD Crucial MX300 de 1 Tera, y debo decir que el iMac literalmente vuela.
    También hace un par de años le sustuí el módulo wifi-bluetooth que venía de serie por otro compatible con bluetooth 4.1 y desde entonces el iMac viene siendo compatible con Airdrop, e incluso al principio con Handoff (luego dejó de funcionar no se por qué). De hecho, en Preferencias/General tengo activada la opción “permitir handoff entre este mac…”
    El chip de la tarjeta gráfica palmó el verano pasado por culpa de un buen calentón de la gráfica (mea culpa) pero se pudo sustituir por otra nueva y ahí está todavía el iMac campeón, aguantando mecha… Jeje.

    Voy a probar de instalar la última versión de Sierra en un disco duro externo s ver que tal se comporta, pero voy a esperar a la versión final (no se si sacarán otra para septiembre).

    ¿Has instalo High Sierra en el Mac Pro 2008 con el mismo Patch que usaste para Sierra? o sea, ¿sirve ese patch de Sierra para High Sierra?

  • #144069

    sault
    Participant

    Es que es una máquina muy decente la que usas. Y con esas actualizaciones realmente poco mas se necesita para la mayoría de usuarios.

    La mayoría de las veces el problema de Handoff se soluciona desconectando y volviendo a conectar la cuenta Icloud. Tanto en el Iphone/Ipad como en el Mac.

    Si, al principio exactamente el mismo. Pero dosdude1 sigue perfeccionando y mejorando la instalación de su parche. Yo me esperaría a la versión definitiva de High Sierra si no estas desarrollando algún proyecto. Las últimas Betas dan problemas en según qué máquinas y configuraciones. No obstante tienes aquí la última versión.

    http://dosdude1.com/highsierra/

    De todas formas, siempre es bueno saber que podrás tener tu mac actualizado en un próximo futuro. ¿no?

  • #144070

    Fai
    Participant

    No solo sería bueno saberlo, sino que en ocasiones sería conveniente tener que actualizar a Sierra o High Sierra, porque en caso de quedarte en El Capitan, no solo te quedas desactualizado respecto al sistema operativo, sino también en las aplicaciones, por ejemplo Xcode, o Pages, Numbers y Keynote, El Capitan no te deja instalar las nuevas versiones. La última versión de Pages que soporta El Capitan es la 5.6.2, y la última soportada de Xcode es la 8.2.1, en tanto que las últimas versiones en Sierra son la 6.2 y la 8.3.3 respectivamente. No entiendo esta política de Apple respecto a la restricción de actualizaciones de las Apps.

    Por lo que veo el parche de Sierra y High Sierra son distintos.

    He descargado el parche de High Sierra del enlace anterior, y se ha descargado un archivo .zip que da error al descomprimirlo. De todos modos no voy a actualizar a la beta de High Sierra.

    Pero si quiero actualizar a Sierra, y después de leer las instrucciones, tengo dos dudas:

    1- ¿Es necesario desactivar permanentemente SIP?

    2- ¿Es necesario descargar el Script para las actualizaciones de software?

    Gracias y un saludo

  • #144071

    sault
    Participant

    1 No sabría decirte. Jamás he habilitado SIP en ninguno de mis macs.

    2. No es necesario

  • #144082

    Fai
    Participant

    Instalado Sierra en un disco duro externo sin problemas. Arranca y se ejecuta perfectamente.

    Lo que ocurre es que se ha desactivado System Integrity Protection (SIP) en el disco duro interno del iMac (El Capitan).

    Al parecer, aunque lo instales en un disco duro externo, el parche desactiva la SIP del iMac. Me imagino que si vuelvo a activar manualmente SIP mediante el comando de terminal csrutil enable, Sierra dejará de funcionar o arrancar desde el disco duro externo.
    El problema es que me deja desprotegido el iMac con El Capitan (a menos que vuelva a activar SIP).

    ¿Hay mucho riesgo de catástrofe o de infección de malware con la SIP desactivada? Carlos en su libro de ponte al mando de El Capitan, y en un excelente post de faq-mac recomendaba que los usuarios comunes no deberíamos desactivar SIP.

    Un saludo.

  • #144135

    sault
    Participant

    Como bien dice Carlos, todos los usuarios “comunes” deberían tener habilitado SIP. Pero SIP no ha existido hasta hace bien poco y Os X siempre ha sido sólido como una roca. Sabiendo lo que uno hace, el riesgo es muy bajo.

    O simplemente instalando Blockblock, que aunque en fase Beta funciona muy bien, puedes saber si algún proceso quiere modificar tus archivos de sistema

    https://objective-see.com/products/blockblock.html

  • #144136

    Fai
    Participant

    Me imagino que mientras no vayamos descargando e instalando cualquier cosa que veamos por internet sin las debidas garantías del desarrollador, y llevando un poco de cuidado con las webs que se visitan, no habrá problemas de malware mientras se tiene SIP desactivada.

    Gracias, y un saludo.

Debes estar registrado para responder a este debate.